Knox Manage license update failure for Android 9 or lower devices in legacy mode
Last updated May 25th, 2026
Categories:
Environment
- Knox Manage
- Android Legacy
- Android 9 and lower
Overview
When using Knox Manage in legacy mode on devices running Android 9 OS or lower, you may encounter an issue where the Update license command sometimes fails to send after adding a new license to the Knox Manage console, causing devices to maintain the old license and their “Expired” status.
Cause
When you send the Update license command, the Knox Manage console starts to sync the new license with devices with expired licenses. Then, the device user must confirm and agree to switch to the new license within a given timeframe. If no action is taken by the device user, the Knox Manage agent displays a timeout error.
On the console, the following errors display in the Update license command history when viewing the command in detail:
Request History: {"ElmLicenseType":"Bck", "ImeiSerial":"", "KnoxLicenseSupport":"Support", "NewKnoxLicenseId":"-1282963373", "NewKnoxLicenseType":"Km", "PreviousKnoxLicenseId":"-1282963373", "PreviousKnoxLicenseType":"Km", "ReportType":"UpdateLicense"}
Result Code: Failed (Internal)
Result History: CommandCode=ReportRequest
Request History: NotificationId=AASdcf59a714725476ca3f74660c807f1f6, {ElmLicenseType=Bck, ImeiSerial=, KnoxLicenseSupport=Support, NewKnoxLicenseId=-1282963373, NewKnoxLicenseType=Km, PreviousKnoxLicenseId=-1282963373, PreviousKnoxLicenseType=Km, ReportType=UpdateLicense}
Result Code: Failed (1901035)
Result History: EMM Agent error occurred
The Failed (1901035) result code is a generic error code returned by the Knox Manage agent, and isn’t related to the device’s Android version.
Resolution
You should inform the device user about the planned license update and ask them to agree to the license update pop-up when it displays on their device.
If the target devices have their language set to Arabic, the pop-up message will not appear (an upcoming fix is planned for this case). Meanwhile, we suggest changing the device language to English before sending the Update license command.
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