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The error “Security policy prevents turning on device administrators” shown when launching apps

Last updated July 26th, 2023

Categories:

Environment

  • Knox Manage (KM)
  • Android Enterprise (AE) Device Owner (DO) mode
  • Knox Service Plugin (KSP)

Overview

When launching an app on a KM-managed device with KSP enabled, some users are receiving the following error:

Security policy prevents turning on device administrators

Cause

If KSP is enabled in the KM console, it will block any application requesting device admin permissions by default.

Resolution

This issue was addressed and fixed in the Knox Manage v20.2 release. You must add the app receiving the error in the device admin allowlist:

  1. In your KM console, select Profile.
  2. From the Knox Service Plugin tab under Samsung Knox Android Enterprise, expand Device-wide policies, and set Enable device policy controls > True.
  3. Expand the Device Admin allowlisting policy menu, and set Enable device admin controls > True.
  4. Add the required device admin applications to Allowlisted DAs.
  5. Click Save > OK.
  6. Click Apply > OK.

Additional information

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