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Devices remain in expired state after changing license

Last updated August 12th, 2024

Categories:

Environment

  • Knox Manage
  • A valid Knox Manage license with the KLM09 prefix
  • An expired Knox Manage license with the KLM12 prefix

Overview

After changing an expired Knox Manage license with the KLM12 prefix to a valid Knox Manage license with the KLM09 prefix, some devices may continue to be in the Expired status.

Cause

The Update License device command doesn’t allow downgrading from a newer Knox Manage license to an older one. If attempted, the current license will expire, resulting in the device getting locked.

  • If both Knox Manage licenses are visible from the tenant, the older license type is labelled as Legacy Knox Manage.

  • Starting with Knox Manage 24.04, you can now change a Knox Manage license with the KLM12 prefix to a Knox Manage license with the KLM09 prefix and a Knox Platform for Enterprise license.

Resolution

To change a Knox Manage license with the KLM12 prefix to an older Knox Manage license with the KLM09 prefix:

  1. On the Knox Manage console, go to Setting > License.
  2. Add a Knox Platform for Enterprise Premium license.
  3. Click Change License. The Select Change License Type dialog opens.
  4. Under Assign License, select Legacy Knox Manage or New Knox Manage (starting with KLM12) → Legacy Knox Manage with KPE.
  5. Click Next.
  6. In the Organization tab, select all organizations that use a Knox Manage license, then click Assign.

To change the license type of individual users, go to the User tab in the Assign License dialog, select the users with a Knox Manage license, and click Assign.

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