Missing Wi-Fi login popup
Last updated November 14th, 2024
Categories:
Environment
- Knox Manage
- Kiosk mode
Overview
Device users may run into an issue when attempting to connect to a Wi-Fi network where the network login popup doesn’t appear and as a result the user is unable to access Wi-Fi.
Cause
This issue occurs because the package com.google.android.captiveportallogin
is missing in the Allowlisted Apps Settings for your kiosk. Without adding this package, the captive portal login doesn’t appear and as a result the user can’t connect to a Wi-Fi network.
Resolution
To resolve this issue, you must add the com.google.android.captiveportallogin
package.
First ensure that this package is enabled as a System Application:
- In the Knox Manage console, click Kiosk.
- Select your kiosk and click Modify.
- Under Component, search for the package
com.google.android.captiveportallogin
. - If the package is found, you can proceed to add it to your Allowlisted Apps Settings, otherwise click Add System Application.
- Enter the following details in Add System App and click Save.
Platform Android Package Name com.google.android.captiveportallogin
Application Name Enter a valid application name (Example: Captive Portal Login)
Next, add this package to your Allowlisted Apps Settings:
- In the Modify Kiosk page, click Select next to Allowlisted Apps Settings.
- Search for
com.google.android.captiveportallogin
and ensure it’s selected. - Click OK.
- Click Save > OK.
- Enter a valid comment to update your kiosk version, then click OK to save your changes.
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