Groups, organizations, and profiles assigned to sub-admin are deleted when switching from original console to new console
Last updated June 30th, 2026
Categories:
Environment
- Knox Manage
- Affected role: Sub-admins with specific groups, organizations, and profile permissions
Overview
When switching from the Knox Manage original console to the Knox Manage new console, you may encounter an issue where the groups, organizations, and profiles previously assigned to sub-admins in the original console may be deleted upon their next login. Other admin roles aren’t affected by this issue.
Cause
Starting with the 26.06 release, some permission settings required to access each console need to be synchronized. As the super admin, you must reconfigure the sub-admin’s permissions to manage specific groups, organizations, and profiles in the Knox Manage new console, as these configurations will serve as the primary source for synchronization of data.
If you don’t configure these permissions in the Knox Manage new console, your data may not be retained when switching between consoles.
Resolution
Before you switch from the Knox Manage original console to the Knox Manage new console, ensure you configure the group, organization, and profile permissions for your sub-admins on the Administrators & Roles tab of the Knox Admin Portal. Once configured, switching between consoles no longer results in data loss.
To configure permissions for the Knox Manage new console:
- Sign in to your Knox Admin Portal, then navigate to Administrators & Roles.
- On the ROLES tab, click CREATE ROLE.
- From the Service dropdown, select Knox Manage.
- Enter a Role name and configure the sub-admin’s Permissions.
- Click SAVE.
- Go to the ADMINS tab, select the sub-admin account, change the Knox Manage role to the newly created custom role, and save the changes.
If you’re still experiencing issues, submit a support ticket.
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