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S Pen Air command unavailable in kiosk mode and lock task mode

Last updated April 21st, 2025

Categories:

Environment

  • Samsung devices with an S Pen
  • Android 9.0 and higher
  • Knox Manage
  • Kiosk mode
  • Android Enterprise

Overview

When using a Samsung device with the S Pen in Knox Manage kiosk mode or as an Android Enterprise managed device in lock task mode, device users may encounter an error when hovering the S Pen near the device screen and pressing the Pen button. Additionally, tapping the Air command icon in kiosk or lock task mode may cause the same error:

Can’t use air commands. Touch and hold the Recents and Back buttons to unpin app, then try again.

Cause

On devices running Android 9.0 and higher, the Air command feature is unavailable in Knox Manage kiosk mode. Air command is also unavailable on Android Enterprise managed devices in lock task mode. Due to these restrictions, an error occurs when attempting to use Air command while in kiosk or lock task mode.

Workaround

To disable the error pop-up, you can block the Air command application in your Knox Service Plugin configuration.

  1. On your EMM console, go to your Knox Service Plugin configuration.
  2. Under Device-wide policies, set Enable device policy controls to True.
  3. Under Application management policies, set Enable application management controls to True.
    • In the Disable Application without user interaction policy field, enter com.samsung.android.service.aircommand.
  4. Click Save & Assign and push the configuration to your device.

Air command is now blocked from running on the device.

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