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How to disable Knox Manage auto-enrollment on Microsoft Entra ID devices

Last updated June 30th, 2025

Categories:

Environment

  • Knox Manage
  • Microsoft Entra ID
  • Devices running Windows OS

Overview

When enrolling a Windows device into Microsoft Entra ID, you may encounter the Knox Manage Terms of Use page despite removing Microsoft Entra ID from your Knox Manage console.

Cause

If you’ve previously connected your Microsoft Entra ID to Knox Manage, Microsoft Entra may be auto-enrolling your Windows devices.

Resolution

To resolve this issue, you can disable auto-enrollment for Knox Manage:

  1. In the Microsoft Azure portal, go to Microsoft Entra ID > Manage > Mobility (MDM and WIP).

  2. Under Name, select Samsung Knox Manage. The Samsung Knox Manage page opens.

  3. To disable auto-enrollment, you can either:

    1. Click Delete to remove the Knox Manage MDM from Microsoft Entra.
    2. Under MDM user scope, select None. This is recommended if you’ll continue using Knox Manage with Microsoft Entra in the future.

    Knox Manage in the Microsoft Azure portal

Alternatively, you can disable auto-enrollment from the Microsoft Entra admin centre:

  1. In the Microsoft Entra admin center, go to Entra ID > Settings > Mobility (MDM and WIP) > Samsung Knox Manage. The Samsung Knox Manage page opens.
  2. To disable auto-enrollment, you can either:
    1. Click Delete to remove the Knox Manage MDM from Microsoft Entra.
    2. Under MDM user scope, select None. This is recommended if you’ll continue using Knox Manage with Microsoft Entra in the future.

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