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License keys page unavailable from the Knox Developer Portal

Last updated July 9th, 2024

Environment

  • Knox SDK
  • Knox Developer Portal

Overview

You might notice that the License keys page is unavailable from the Knox Developer Portal.

Cause

The Samsung Knox SDK team implemented changes to the Knox SDK framework in order to further secure the privacy and data of Galaxy device users. As a result of these changes, we’ve made adjustments to how we distribute developer licenses to our enterprise customers. The License keys page is now only available to approved enterprise customers with valid Samsung Knox use cases.

Workaround

If you require a Knox developer license, you’ll have to submit a support ticket and provide a business use case for your app. To do this:

  1. Navigate to the Knox Partner Program Portal, then click Support.

  2. On the Support page, click the Partnership, benefits, and accounts tile, then click SUBMIT A TICKET.

    submit a ticket under the partnerships, benefits and accounts tile

  3. If you do not see the Partnership, benefits, and accounts tile, click any of the available tiles that has the support ticket option and click SUBMIT A TICKET.

  4. On the support ticket page, click Create a Case, then under Support Category, select Knox Partner Program.

  5. Provide your location, then click Next.

  6. In the Subject field, enter “I need access to the Knox Developer Portal License keys page”.

  7. In the Description field, provide the following information:

    • Your name, company name, website, and physical address
    • Your email and phone number
    • Links to your Google Play or Apple Store apps
    • Your app information (app name, app build ID/package name, app key features)
    • A description of your business use case
    • The name and contact info of your Samsung Knox account rep.

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