Device doesn’t perform factory reset or receive software updates via FOTA

Last updated June 22nd, 2026

Environment

  • Android Enterprise
  • Knox SDK

Overview

You may notice an issue where a device doesn’t perform a factory reset after reaching the maximum failed password attempts, even if you configured the limit using the Android API method DevicePolicyManager.setMaximumFailedPasswordsForWipe. Additionally, the device may be unable to receive software updates via Firmware Over-The-Air (FOTA).

Cause

When RestrictionPolicy.allowPowerOff() is set to false, it disables all options for powering off the device, inlcuding:

  • Pressing the power button
  • Using the quick panel option to turn off the device
  • Performing a factory reset

Since a factory reset requires the device to power off, enabling this restriction prevents the factory reset process from completing. Additionally, this policy prevents device software updates via FOTA as they require the device to reboot, which is also blocked by this restriction.

Resolution

To successfully perform a factory reset or receive software updates via FOTA, ensure that the allowPowerOff policy is not set to false. The device must be able to power off and reboot for these operations to complete.

If you’re still experiencing issues, submit a support ticket.

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