Back to top

Unable to edit contact information on lock screen

Last updated June 12th, 2023

Categories:

Environment

  • Knox Platform for Enterprise
  • Android Enterprise
  • Samsung devices running Android 13 (One UI 5.1 and lower)
  • Company owned business only device

Overview

After enrolling a device as a company owned business only device, device users may encounter the following error message when trying to edit the contact information on the lock screen:

Action not allowed

You do not have permission to perform this action. Contact your organization's IT administrator for more information.

Cause

This issue is caused by a concept code migration when the device is updated to Android 13.

Workaround

The contact information field can be updated by the IT admin with the setDeviceOwnerLockScreenInfo method.

This workaround will prevent the device user from updating the contact information field even after the fix. All future updates must be done by the IT admin.

A fix to this issue has been scheduled for the One UI 5.1.1 release.

Is this page helpful?