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Device in AE DO mode requires factory reset when Knox Platform for Enterprise license expires or is deactivated

Last updated July 26th, 2023

Categories:

Environment

  • Knox Platform for Enterprise (KPE)
  • Android Enterprise (AE) Device Owner (DO) mode

Overview

Some users are reporting that their devices, enrolled in DO mode, are prompted to factory reset when the associated KPE license expires or is deactivated.

Cause

In the event that a KPE license expires on a device enrolled in Profile Owner (PO) mode, the work profile is removed without requiring a factory reset.

However, in DO mode, the work profile is equivalent to the device and cannot be removed as in PO mode. To ensure the device removes all activity associated with the work profile, it must be factory reset.

If a new KPE license is associated with the device after it is prompted to factory reset, its work data and profile are restored.

Resolution

This is an expected behavior of the work profile. After the KPE license associated with a device in DO mode expires or is deactivated, and the device is then powered off or rebooted, a factory reset is required to ensure that the work profile is fully removed.

Workaround

To avoid encountering the factory reset prompt, please check the expiry dates of your KPE licenses and ensure you renew them before they expire. To do so:

  1. Sign in to the Knox Admin Portal.

  2. On the Licenses page, click Manage license keys.

  3. In the Check license keys field, enter your KPE license key.

Your KPE license details, including your license’s expiry dates, appear in a text box.

For more information about KPE licenses, see Knox Platform for Enterprise licenses.

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