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Device randomly reboots without warning

Last updated May 15th, 2024

Categories:

Environment

  • Android Enterprise
  • Any EMM
  • Devices running Android 10 or higher

Overview

You may encounter an issue where your device reboots without warning at unpredictable intervals. When viewing the device dumpstate logs, the following message is displayed:

Line 237947: 2023-05-24 16:10:00-0400 | REBOOT | | REASON: enterprise,mainline_update

Cause

As a requirement of Google Play system updates, devices must be restarted whenever mainline updates get applied. If your EMM profile’s System Update policy is enabled and set to Automatic, a mainline update can be applied — and the device can restart at any time — without user interaction.

Mainline updates are separate from Android Security Maintenance Releases (SMRs) and Android version updates, and can occur independently.

Resolution

As of April 2024, a fix for this issue was released from Google. Mainline updates no longer force a restart from a device. Instead, mainline updates are now scheduled to update on the next user, admin, or policy-initiated reboot.

Workaround

If the issue persists, there are several methods to prevent unexpected mainline updates:

  • Disable the System Update policy on the device.
  • Postpone all updates on the device with the System Update policy.
  • Configure an update maintenance window with the System Update policy.

The exact steps to update the System Update policy are different for each EMM. Please consult your EMM’s documentation for more details.

Knox E-FOTA can schedule updates for SMRs and Android version updates, but not mainline updates. If you configure the System Update policy through your EMM, you can pause mainline updates. With this policy in combination with Knox E-FOTA, you can manage all three types of system updates.

To disable the System Update policy:

  1. On your EMM, go to the Android Enterprise configuration.
  2. Ensure System > System Update is left unconfigured.
  3. Save and apply your changes to the affected devices.

To postpone updates with the System Update policy:

  1. On your EMM, go to the Android Enterprise configuration.

  2. Modify the following policy:

    • System > System UpdatePostpone

    • Freeze Period — Select start and end dates for when you want to prevent updates.

  3. Click + to add the configuration.

  4. Save and apply your changes to the affected devices.

Updates can only be postponed for 30 days. After 30 days, the device user is prompted to update and restart the device.

To configure an update maintenance window with the System Update policy:

  1. On your EMM, go to the Android Enterprise configuration.

  2. Modify the following policy:

    • System > System UpdateWindowed

    • Schedule (Start – End Time) — Enter the start and end times for the software update.

    • Freeze Period — Select the start and end date for when you want to prevent updates.

  3. Click + to add the configuration.

  4. Save and apply your changes to the affected devices.

If the device continues to reboot, submit a support ticket.

Additional information

For more information about the System Update policy types, refer to Manage system updates in the Android developer documentation.

For more information about Knox E-FOTA, refer to the Knox E-FOTA admin guide.

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