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Frequent multi-factor authentication requests with Samsung Email

Last updated April 11th, 2025

Categories:

Environment

  • Samsung Email v6.2.01.1 and higher
  • Microsoft Authenticator app
  • Knox Platform for Enterprise
  • EMMs

Overview

After logging in using multi-factor authentication on Samsung Email v6.2.01.1 and higher, you may notice an issue where the Microsoft Authenticator app notifies device users several times a day that their login has failed.

Cause

The Samsung Email team has identified three potential causes of this issue:

  1. When the Microsoft Authenticator app enters battery optimization mode, the app may briefly disconnect from the network and cause authentication to fail. A workaround is provided to resolve this.
  2. In Samsung Email v6.2.01.1, a bug causes the Microsoft Authenticator app to request for re-authentication every time a session response delay occurs. The Samsung Email team is resolving this bug in a future version update.
  3. There is an issue with how Samsung Email syncs account information with the Microsoft Authentication Library. The Samsung Email team is working with Microsoft to investigate this issue.

Workaround

As a temporary workaround to mitigate the frequent authentication requests, device users can turn off battery optimization in Microsoft Authenticator.

  1. Open the Microsoft Authenticator app.
  2. Tap the three-dot menu icon in the top right corner and select Turn off battery optimization.
  3. Tap Allow to confirm.

You can also disable battery optimization for Microsoft Authenticator on devices configured with Knox Service Plugin policies.

  1. On your EMM console, go to your Knox Service Plugin configuration.
  2. Under Device-wide policies or Work profile policies (Profile Owner), open the Application management policies (Premium) group.
  3. Set Enable application management controls to True.
  4. Under Battery optimization allowlist, click Add.
  5. Add the Microsoft Authenticator app (com.azure.authenticator package) to the list.
  6. Save the profile and apply the changes to enrolled devices.

If you are still encountering this issue after disabling battery optimization, please submit a support ticket with your device logs.

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