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Smart Switch not transferring data to new devices

Last updated November 14th, 2024

Categories:

Environment

  • Android Enterprise
  • EMMs
  • Samsung Smart Switch

Overview

Device users may encounter an issue when migrating from an existing device, where data and settings aren’t transferred to the new device. The issue occurs even if Samsung Smart Switch is enabled via their EMM.

Some example of errors on the device logs:

[SmartSwitch]CategoryInfo: NOT SUPPORT : getPackageName [UI_SETTING] [SmartSwitch]CategoryInfo: NOT SUPPORT : getPackageName [UI_ACCOUNTTRANSFER] [SmartSwitch]CategoryInfo: NOT SUPPORT : getPackageName [UI_HOMESCREEN]

Cause

This issue occurs when the Smart Switch Assistant isn’t installed or hasn’t been enabled as a system app.

For fully managed devices, the Smart Switch Assistant comes preloaded but not enabled.

Resolution

Enable the Smart Switch Assistant (com.samsung.android.smartswitchassistant) from your EMM to resolve the issue. Please consult your EMM’s documentation on how to enable a system app.

If you are using Knox Manage as your EMM, follow the steps outlined in Enable or disable a specific system app.

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