Devices still visible in common device list after deletion from individual services

Last updated July 13th, 2026

Categories:

Environment

  • Knox Admin Portal

Overview

After the 26.06 release, you may notice that a device continues to display in the common device list on the Knox Admin Portal’s Devices page even after it’s deleted from all individual services.

Cause

Prior to the 26.06 release, if a device was deleted from all individual services, it was subsequently deleted from the common device list in the Knox Admin Portal. However, after the 26.06 release, the device remains on the common device list and is available for you to re-register it to your Knox cloud services.

Resolution

To completely remove a device from the common device list, request your reseller to delete the device on your behalf, or delete the device directly from the common device list.

If you’re still experiencing issues, submit a support ticket.

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