Screen timeout policy doesn’t apply when Power saving mode is active

Last updated June 24th, 2026

Categories:

Environment

  • Knox Service Plugin
  • Android 15 or higher

Overview

When using Knox Service Plugin on devices running Android 15 OS or higher, you may encounter an issue where the Screen timeout policy defaults to 30 seconds when Power saving mode is active on the device.

Cause

Starting with Android 15, the Screen timeout policy is overridden by the Device care package when Power saving is On. As Android Open-Source Project (AOSP) configurations take priority over Knox Service Plugin configurations, the Screen timeout value defaults to 30 seconds during Power saving mode.

Resolution

To prevent policy conflicts, set the Allow power saving mode policy to False. To set this policy:

  1. On your Enterprise Mobile Management (EMM) console, go to the Knox Service Plugin configuration.

  2. Under Device-wide policies, configure the following policies:

    Policy Value
    Enable device policy controls True
    Device Restrictions > Enable device restriction controls True
    Device Restrictions > Allow power saving mode False
  3. Push the profile to your device fleet.

Some EMM solutions implement the same allowPowerSavingMode() method as Knox Service Plugin. If the power saving policy is enabled in both solutions at the same time, a policy conflict may occur. To prevent this, we recommend that you configure the power saving policy in your EMM solution and use Knox Service Plugin only for policies available exclusively through Knox Service Plugin and Knox Platform for Enterprise.

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