Unable to access the internet from a mobile hotspot
Last updated December 15th, 2023
Categories:
Environment
- Knox Platform for Enterprise
- Android Enterprise
- Device hotspot using a VPN
Overview
When a device, on which VPN is enabled, is used to create a mobile hotspot, the devices connected to the hotspot may not be able to access the internet.
Cause
If a mobile hotspot is created using a host device that uses any VPN, the Domain Name System (DNS) service running on the host device becomes unresponsive.
The Knox Platform for Enterprise team is aware of the issue, and is currently working on a fix.
Workaround
To be able to connect to the internet, device users connecting to the hotspot must change the DNS IP address of their device to that of a public server.
The following table provides examples of public DNS servers:
Public DNS provider | IP address |
---|---|
8.8.8.8 | |
CloudFlare | 1.1.1.1 |
Quad9 | 9.9.9.9 |
On this page
Is this page helpful?