Uploaded devices not visible on the Knox Mobile Enrollment Devices page when reseller uses profile alias

Last updated June 24th, 2026

Categories:

Environment

  • Knox Mobile Enrollment

Overview

When a reseller uploads your device(s) using a profile alias, you may encounter an issue where they don’t appear on the Knox Mobile Enrollment Devices page. However, these devices are visible in the common device list on the Knox Admin Portal Devices page and are properly assigned to the profile.

Cause

This issue occurs when the following conditions are met:

  1. An enrollment profile is not selcted from the Assign default enrollment profile drop-down on the Manage reseller preferences page, but additional profiles with profile aliases are specified.
  2. A reseller uploads device(s) and assigns an enrollment profile using its profile alias.

Workaround

To allow the device(s) to appear in the Knox Mobile Enrollment Devices page, the device(s) can be re-assigned the same enrollment profile from the common device list or using bulk actions.

Resolution

The Knox Mobile Enrollment team is aware of this issue, and is currently working on a fix.

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