Uploaded devices not visible on the Knox Mobile Enrollment Devices page when reseller uses profile alias

Last updated June 24th, 2026

Categories:

Environment

  • Knox Mobile Enrollment

Overview

When a reseller uses a profile alias to assign an enrollment profile to uploaded devices, you may encounter an issue where the devices don’t appear on the Knox Mobile Enrollment Devices page. However, these devices are visible in the common device list on the Knox Admin Portal Devices page and are properly assigned to the profile.

Cause

This issue occurs when:

  1. On the Manage reseller preferences page, no default enrollment profile is specified in the Assign default enrollment profile drop-down, but additional enrollment profiles with profile aliases are specified.
  2. A reseller uploads device(s) and uses one of the profile aliases to assign an enrollment profile.

Workaround

To allow the device(s) to appear in the Knox Mobile Enrollment Devices page, the device(s) can be re-assigned the same enrollment profile from the common device list or using bulk actions.

Resolution

The Knox Mobile Enrollment team is aware of this issue, and is currently working on a fix.

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