Unable to add a Knox Suite - Essentials Plan license to the Knox Admin Portal due to a permission error
Last updated June 24th, 2026
Environment
- Knox Admin Portal
- Knox Manage
- Knox Suite - Essentials Plan
Overview
When you try to enter a new Knox Suite - Essentials Plan license in Knox Admin Portal, you may encounter the following error:
You don’t have permission to add this license. Please contact your company administrator if you think this is an error
Cause
If you’re experiencing this error as the super admin of the tenant, or if you have confirmed with your super admin that you are assigned the correct permissions to add a license key to the Knox Admin Portal, you may be encountering the error because your account status is still in the Pending state for the Knox Manage service of the tenant.
Resolution
As the super admin of the tenant, navigate to the Administrators & Roles page. Under the ADMINS tab, you will see a list of your admins and the services that are active for them. If you see Pending under KNOX MANAGE, you will need to set up the service for your tenant.
To set up your Knox Manage tenant:
- Click Knox Manage in the Knox Admin Portal navigation pane. If you don’t see Knox Manage in your navigation pane, click your account icon, then click Settings to open the settings page. Click SHOW/HIDE SERVICES and select Knox Manage, then click CONFIRM to enable it.
- You will be prompted to set up your Knox Manage account. If you already have a Knox Manage account, but you are not being redirected correctly, please submit a support ticket and request to correct the link between the services. Please specify your Knox Manage tenant ID and your Knox customer ID in your ticket.
- If the Knox Manage service is active in the tenant, please ensure that your admins are invited to the service. Additionally, ensure that the invited admins are able to launch the service by clicking Knox Manage from their navigation pane.
If you’re still experiencing issues, submit a support ticket and include your Knox Manage tenant ID and Knox customer ID in the ticket description.
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