Unable to delete expired Knox licenses
Last updated May 22nd, 2025
Environment
- Knox Admin Portal
- Knox Suite license
Overview
After your Knox Suite license expires, you may encounter an issue where the Knox Admin Portal still shows devices activated under the license, even after unenrolling the devices from all related Knox services and their consoles. When clicking the expired license, only the Replace license button is available, preventing deletion.
Cause
The Samsung Knox team has identified this discrepancy with expired licenses in the Knox Admin Portal. We are working to resolve this in a future release.
Workaround
If you encounter this issue, you can delete an expired Knox license from your Knox Admin Portal with the help of our support team:
- Unenroll all devices assigned to the license from the associated Knox services.
- Submit a support ticket requesting deactivation of the devices. Once Samsung Support deactivates your devices, the Delete license option is available in your Knox Admin Portal.
- Click Delete license to remove the expired Knox license.
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