Unable to create or edit an enrollment profile in Knox Mobile Enrollment
Last updated July 2nd, 2026
Categories:
Environment
- Knox Mobile Enrollment
Overview
When you attempt to create a new enrollment profile or edit an existing enrollment profile in Knox Mobile Enrollment, you may encounter the following error message:
Couldn’t create enrollment profile. Try again later.
Cause
Prior to the 26.06 release, the Support phone number field accepted special characters, such as hyphens (-) and plus signs (+). However, starting with 26.06 release, this field only accepts numeric characters (0 to 9). As a result:
- When you create a new enrollment profile, you can no longer enter special characters in the Support phone number field.
- When you edit an existing enrollment profile, if the Support phone number field contains special characters, you won’t be able to save the profile.
Resolution
Enter the Support phone number using only numeric characters (for example, 9871234560). Remove any special characters, such as hyphens and plus signs.
If you’re still experiencing issues, submit a support ticket.
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