Authentication fails due to expired access token
Last updated July 18th, 2024
Environment
- Knox cloud services API
Overview
You may encounter the following error while generating a signed access token:
{
"code": [
4030000
],
"message": [
"AUTHENTICATION_FAIL"
],
"data": [
"Failed to parse jwt token for user <user_email> with any user public key: access token has expired"
]
}
Cause
The access token is set based on your device’s local time. If the time zone setting on your device does not match the time zone from which the API request originated, the authenticating server will deem the access token as expired.
Resolution
Ensure your device’s local time is set to the same time zone that was used while generating the access token request.
On this page
Is this page helpful?