Back to top

MSPs unable to migrate KM customers who have an existing KM tenant

Last updated March 29th, 2023

Environment

  • Knox Manage
  • Knox MSP Program

Overview

You may encounter either of the following issues when trying to migrate an existing Knox Manage customer to the Knox MSP Portal:

  • When adding an existing Knox Manage Tenant ID prefix, the portal returns with the following error:

    The organization domain, Organization name, is already in use. Please add a prefix to uniquely identify your organization or to manage multiple Knox Manage administrator accounts under the same organization.

  • When adding a new Knox Manage Tenant ID prefix, the following error is displayed:

    customerId is duplicated.

Cause

Existing Knox Manage tenants with duplicate emails can’t be migrated to the Knox MSP Portal, as email addresses are unique keys used to distinguish customer accounts.

This issue occurs in the following cases:

  1. If multiple admins in a Knox Manage tenant have the same email address.

    • For example, KM tenant abc.com has 2 admins — one admin with account admin@abc.com and another admin with account admin@abc.com.
  2. If multiple admins in multiple Knox Manage tenants have the same email address.

    • For example, an admin with account admin@abc.com exists in Knox Manage tenants abc.com and def.com.

Resolution

To resolve this issue, submit a support ticket with the following information:

  • Customer ID
  • Knox account
  • Knox Manage Tenant ID(s) if possible
  • Whether you want all Knox Manage tenants deleted so the MSP can create new ones, or which Tenant ID(s) you want to keep or remove.

Is this page helpful?