Jointly managed customer account missing MSP settings after registration
Last updated February 2nd, 2026
Environment
- Knox MSP Portal
Overview
When a customer signs up for a Knox account using their work email address directly at SamsungKnox.com, they may experience an issue where the settings configured by their MSP are missing, and the MSP can’t manage their account.
This occurs because registering through SamsungKnox.com creates a new Knox account separate from the account their MSP has already created on their behalf. As a result, jointly managed customers don’t see the data and settings configured by their MSP, and the MSP loses the ability to manage that customer.
Cause
With the introduction of Samsung account for Business, account IDs (not email addresses) are now used as unique identifiers. If a customer signs up directly at SamsungKnox.com using their work email, this creates a separate account independent from any jointly managed customer account their MSP may have already created.
Following the Knox MSP Portal 25.11 release, when MSPs add customers for joint management or transition existing customers to the jointly managed status, the system automatically sends email invitations with sign-up links that expire after seven days. Jointly managed customers must use the Get started link provided in their email invitation to register their Knox accounts before the end of the expiration window.
If customers don’t use the MSP’s email invitation link, and choose to register directly at SamsungKnox.com instead, they can’t be managed by the MSP.
Resolution
If the customer mistakenly made a separate account instead of using the email invitation link to complete the registration, there are two ways to resolve the issue:
- (Recommended) Add the customer’s new account in the MSP portal.
- Add the MSP created account to Samsung account for Business.
Add the customer’s new account in the MSP portal
The recommended resolution is for the MSP to add the customer’s newly created account to the Knox MSP portal and delink the previously created customer account. Then, you can continue to manage the customer through their self-created account.
Add the MSP-created account to Samsung account for Business
If it isn’t possible to delink the previously created customer account, you’ll need to direct your customer to add the MSP-created customer account as a new admin in Samsung account for Business.
The following steps are written from the perspective of the customer accessing Samsung account for Business console.
To add the MSP-created account as an admin:
-
Navigate to the Samsung account for Business console.
-
Click Add user on the Users page. The Add users page opens.
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Enter the following user details:
- First name
- Middle name (optional)
- Last name
- Work email
- Division (optional)
- Department (optional)
- User ID
- Domain
- Location: Default location
- Role: Admin
-
Click Create. A confirmation screen with the account ID of the new user displays.
-
Check your email address for an activation email. This email contains your sign-in details and a link to activate your account — you’ll have seven days to activate your account through this link. After that, a MSP admin will need to resend the activation email to you. Once you’ve activated your account, the status of the user on the the Users page will change from Pending to Active.
-
Once a user is added, you must use the link previously sent by the MSP to complete your Knox registration. Before you click on the invitation link, ensure that you’re not signed into any Samsung account for Business portals or Knox portals.
-
On the Sign up for Samsung account for Business page, click Sign in.
Ensure you don’t click Sign up.
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Enter the account ID provided in the activation email.
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Complete the rest of the registration steps.
Once completed, you’ll be redirected to the Knox Admin Portal with access to the data and settings configured by your Managed Service Provider.
Additional information
If you have any other questions, you can submit a support ticket.
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