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Unable to place phone calls in kiosk mode

Last updated July 20th, 2023

Categories:

Environment

  • Knox Service Plugin
  • Third-party EMMs
  • Kiosk mode

Overview

When attempting to make a phone call on a device in kiosk mode, device users may encounter an issue where they can’t initiate the call after dialing.

Cause

To make a call on devices in kiosk mode, certain packages must be allowed by the EMM. Once these packages are added, the device user can place calls.

Resolution

To enable phone calls in kiosk mode:

  1. On your EMM console, go to the Knox Service Plugin configuration.

  2. Add the following packages to the Device-wide policies > Application management policies > Application Allowlist by Pkg Name policy:

    • com.samsung.android.app.contacts
    • com.samsung.android.dialer
    • com.android.server.telecom
    • com.samsung.android.incallu
    • com.android.incallui.call.dialog
  3. Save and push your changes to the affected devices.

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