Disable Internet Connectivity causes unexpected network reconnection behavior
Last updated December 8th, 2025
Categories:
Environment
- Knox Service Plugin
- Android 13 or higher
Overview
On your EMM console, within your Knox Service Plugin configuration, when WiFi > Disable internet connectivity is set to On, the setting initially functions as intended. However, when the network connection becomes unstable, the Wi-Fi icon may display an exclamation mark or automatic reconnection may be unexpectedly blocked.
Cause
If you’ve set Disable internet connectivity to On, the device doesn’t immediately check for Internet accessibility when it initially connects to a network. The connection process works as expected.
However, if the established network becomes unstable or unreliable — for example, when your device doesn’t receive Address Resolution Protocol responses from the Access Point within the allowed timeframe — the device creates a new network connection in the background.
When the new network connection is created, the device establishes a duplicate connection to the same SSID (network name) that it’s currently using. The device copies the existing network configuration and attempts to renew its DHCP lease to restore stable connectivity. This background process runs without disconnecting the device from the network. From the user’s perspective, the device remains connected to the same network the entire time.
When the device attempts to verify Internet connectivity on this newly created background network, it may determine there’s no Internet connection available. As a result, the Disable internet connectivity settting fails to apply to the newly created background network. This results in unexpected behavior where although the device appears to be connected to Wi-Fi, it may either switch to mobile data or display an exclamation mark on the Wi-Fi icon to indicate there’s no Internet access instead.
Additionally, this may prevent devices from automatically reconnecting to previously unstable Wi-Fi networks.
Resolution
The issue occurs on devices running Android 13 OS or higher, and is resolved in the One UI 8.5 update. Ensure your devices are updated to Android 16 with One UI 8.5 or higher to apply this resolution.
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