Device undergoes inadvertent factory reset
Last updated September 24th, 2025
Categories:
Environment
- Android Enterprise
- Knox Service Plugin
Overview
You may encounter an issue where your device inexplicably undergoes a factory reset. This may result in loss of device data.
Cause
A factory reset can occur if you exceed the number of allowed failed password attempts, causing device data to be wiped. Incorrect password submissions may occur involuntarily due to your device screen registering inadvertent touches. This can trigger the Knox Service Plugin Maximum Failed Password Attempt to Wipe Data policy or the setMaximumFailedPasswordsForWipe API.
Workaround
To reduce the frequency of failed password attempts, you can enable Accidental Touch Protection and disable Extra Touch Sensitivity so that your device is less likely to register inadvertent touches.
To configure your Accidental Touch Protection and Extra Touch Sensitivity settings:
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On your EMM console, go to your Knox Service Plugin configuration.
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Configure the following Device-wide policies:
Policy Value Enable device policy controls True Device customization controls (Premium) > Enable device customization True -
Under Device and Settings customization profile (Premium) > Configure values and settings menu, create the following configuration (by default, the first configuration is called Configuration 1):
Field Value Name of the Setting item Display > Accidental touch protection Set value for the setting On Allow end-user modification of this setting False Configure to hide settings False -
Click Add and create the following configuration (by default, this configuration is called Configuration 2):
Field Value Name of the Setting item Display > Touch Set value for the setting Off Allow end-user modification of this setting False Configure to hide settings False -
Save the profile and apply the changes to your devices.
If the issue persists, submit a support ticket.
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