Separated Apps folder not generated
Last updated October 17th, 2024
Categories:
Environment
- Knox Service Plugin
- Devices running Android 14
- Separated Apps
Overview
When Knox Service Plugin is used to activate a Knox license, you may notice that the Separated Apps folder isn’t generated and doesn’t appear on a device.
Cause
Separated Apps requires a valid Knox license. If Knox Service Plugin policies are configured, Knox Service Plugin performs the Knox license activation (provided there is an existing license).
However, during a device’s initial set up, Separated Apps may start up before Knox Service Plugin can activate your license. As a result, the Separated Apps folder doesn’t appear on the device.
Resolution
If you are using Knox Service Plugin to activate and apply your Knox license, please reboot your device.
Alternatively, you can directly use your EMM to activate your Knox license to avoid rebooting your device.
Additional Information
To learn more about Separated Apps, visit Separated Apps for Android 14.
To learn more about managing Knox licenses visit Knox Platform for Enterprise licenses.
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