Policies not applying after installation on device
Last updated March 27th, 2024
Categories:
Environment
- Knox Service Plugin
- Android Enterprise
Overview
When installing the Knox Service Plugin app on a device, you might encounter an issue where your configured policies aren’t automatically applied after the installation completes.
Cause
To apply Knox policies to your device, Knox Service Plugin must run as a foreground app.
Due to a change in how foreground apps are managed in Android, only apps with special permissions can run in the foreground without user interaction.
For most Samsung devices, Knox Service Plugin can run in the foreground. However, for select models, it can’t run in the foreground without a one-time interaction from the device user, as it doesn’t have the necessary permissions.
The following models are affected:
Series | Model |
---|---|
Galaxy A |
A10s (One UI Core) A20s (One UI Core) A01 A02 A02s (One UI Core) A11 (One UI Core) A12 A21 (One UI Core) A21s |
Galaxy M |
M10 M01 (One UI Core) M11 (One UI Core) M12 M02 M20 M21 M30 M31 M31s M40 M50 M51 |
Galaxy F | F12 |
Galaxy Tab |
Tab A7 (One UI Core) Tab A7 Lite (One UI Core) Tab A8 (One UI Core) |
Workaround
To resolve the issue, you must add the Knox Service Plugin package (com.samsung.android.knox.kpu) to the battery optimization allowlist for all affected devices in your fleet. This process exempts the Knox Service Plugin app from any foreground service restrictions.
The process for this procedure depends on your EMM. Consult your EMM’s documentation for more information.
If your EMM doesn’t support battery optimization, you can manually configure this setting on the device:
- On your device, go to Settings.
- Tap Apps, then select Knox Service Plugin.
- Tap Battery, and select Unrestricted.
- Re-apply the policies to the device. This can be done from your EMM console, or by tapping Apply latest policies in the Knox Service Plugin app if debug mode is enabled.
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