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Device losing permissions after upgrading to Android 13

Last updated March 24th, 2023

Categories:

Environment

  • Knox Platform for Enterprise
  • Android Enterprise

Overview

After upgrading an enrolled device from Android 12 to 13 (with One UI 4.x to One UI 5.x), device users may encounter an error where the device is unable to find existing licenses. These devices may lose any granted Knox permissions, and any configurations that are deployed will not be applied.

When trying to get the license information or deactivate an existing license, the following response is found in the logs:

Licenses not found

Cause

When updating to Android 13 (One UI 5.0), the license agent was modified, and the device attempts to retrieve the license information from a new location. For devices shipped with Android 10 or lower, this new location cannot be accessed and previously stored licenses cannot be retrieved.

This issue affects models that were shipped by Samsung with Android API level 29 or lower, and have received a FOTA update to One UI 5.0. Newer devices (devices with first OS higher than Android 11) are not affected by this issue.

Resolution

A fix has already been released in the One UI 5.1 update. Device users are able to verify their One UI version by going to Settings > About phone > Software information on their device.

One UI Software Information

If the device is running One UI 5.1, the issue can be resolved by re-enrolling the affected device. Re-enrolling when the device is running One UI 5.0 will solve the issue, but the device will need to be re-enrolled again after updating to One UI 5.1.

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