Connected without internet status after connecting to Wi-Fi
Last updated December 15th, 2023
Categories:
Environment
- Knox Platform for Enterprise
- Android Enterprise
- Company-owned device with a work profile
- Device-wide VPN
Overview
After connecting to a Wi-Fi network, device users may encounter an issue where the Wi-Fi connection shows the following status:
Connected without internet
Cause
In enterprise environments where an device-wide VPN is being used, all internet traffic is routed though that VPN. When the device tries to confirm the internet connection though Wi-Fi, the traffic to the captive portal checkpoint is blocked.
The device fails to connect to the following captive portal checkpoint URLs:
- http(s)://www.google.com/generate_204
- http(s)://connectivitycheck.gstatic.com/generate_204
- http(s)://play.googleapis.com/generate_204
Resolution
To resolve the issue, add the following packages to the VPN exception list:
- com.android.vending
- com.google.android.apps.gcs
- com.google.android.gms
- com.sec.android.app.sbrowser
The procedure for this process depends on your EMM. Consult your EMM’s documentation for more information.
On this page
Is this page helpful?