createApnSettings returns -1 ‘Invalid MVNO type’ error
Last updated July 26th, 2023
Categories:
Environment
- Knox SDK
- Knox 3.4 (API Level 29)
Overview
When creating or updating the APN Settings with the Knox SDK methods ApnSettingsPolicy.createApnSettings or ApnsSettingsPolicy.updateApnSetting, the return value is -1, Invalid MVNO type.
The following error appears in the log file:
ApnSettingsPolicyService: Invalid mvno type!
ApnSettingsPolicy: createApnSettings: -1
The ApnSettings object passed as a parameter to the method also has its mvno_type field set as a string value that is not:
- empty string
- MVNO_SPN
- MVNO_IMSI
- MVNO+GID
Cause
There are two reasons for the invalid MVNO type error:
-
From Knox API Level 29 (Knox version 3.4/Android P), ApnSettings.mvno_type and ApnSettings.mvno_value are required fields. If the APN does not require a MVNO type and value, you must enter empty strings in the MVNO type and value fields.
-
Due to a defect, the Knox framework was unable to configure ApnSettings.mvno_type and ApnSettings.mvno_value fields on the device.
Resolution
For customers to be able to configure or update their APN Settings, ensure the conditions below are met:
-
On devices running Knox 3.4 and higher, your UEM partner must update their implementation to support the mvno_type and mvno_value fields in the ApnSettings class. For details, please refer to the Knox SDK documentation.
-
The customer must update the firmware containing the fix that allows the MVNO type and value to be set with the Knox SDK.
The list below shows some common device models and their build numbers, but is not exhaustive. Please contact Samsung Knox Support for the build number of your particular device model.
Device | Region | Model Number | Build number |
---|---|---|---|
Galaxy Note10+ | Europe | SM-N975F | N975FXXU1ASHE |
Galaxy Note10+ | United States | SM-N975U | N975USQU1ASHB |
Galaxy Note10 | Europe | SM-N970F | N970FXXU1ASHE |
Galaxy Note10 | United States | SM-N970U | N970USQU1ASH4 |
Galaxy Note9 | Europe | SM-N960F | N960FXXU3CSI3 |
Galaxy Note9 | United States | SM-N960U | N960USQU2CSI1 |
Galaxy S10e | Europe | SM-G970F | G970FXXU3ASIG |
Galaxy S10e | United States | SM-G970U | G970USQU2BSIO |
Galaxy S10 | Europe | SM-G973F | G973FXXU3ASIG |
Galaxy S10 | United States | SM-G973U | G973USQU2BSIO |
Galaxy S10+ | Europe | SM-G975FC | G975FXXU3ASIG |
Galaxy S10+ | United States | SM-G975U | G975USQU2BSIO |
Galaxy S9 | Europe | SM-G960F | G960FXXS7CSI5 |
Galaxy S9 | United States | SM-G960U | G960USQU6CSI2 |
Galaxy S9+ | Europe | SM-G965F | G965FXXU7CSK1 |
Galaxy S9+ | United States | SM-G965U | G965USQU6CSI2 |
Additional information
If you require further troubleshooting assistance, please raise a support request through the Knox Admin Portal with the following details:
-
A device dumpstate captured after the APN is created
-
A list of all the APNs and the value of each APN field (obtained by inserting the SIM card into a device and listing the values from the device’s Settings app)
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