Samsung Email account cannot be removed on managed device
Last updated July 26th, 2023
Categories:
Environment
- Knox Platform for Enterprise (KPE)
- Samsung Email
Overview
If a Samsung Email account is set up using an Email profile, it can be removed with the Remove button in the account settings.
However, if the account is set up on a device using managed app configuration, the following error message appears when Remove is selected:
The security policy restricts the removal of this account.
Cause
Due to KPE’s system architecture, a UEM continues to push an email account to a device even after an end user deletes it. To prevent issues where the account is repeatedly pushed to the device, the Remove feature in the Email app is restricted for the user.
Resolution
This behavior is by design. Only IT admins can handle Email accounts set up through managed app configuration.
Additional information
For more about managed configurations, see the Knox Developer Documentation.
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