Forced to change password after expiration on devices running Android 15 OS

Last updated August 15th, 2025

Categories:

Environment

  • Android Enterprise
  • Corporate-owned devices with a work profile
  • Samsung devices running Android 15 OS
  • Knox Platform for Enterprise

Overview

On Android Enterprise corporate-owned Samsung devices with a work profile, you may encounter an issue with password expiration if the device is running Android 15 OS. If the device is configured with a password expiration policy on the work and personal lock screen passwords, a prompt screen forces the device user to change the password immediately when the expiry notification appears.

Cause

The Samsung Knox team has identified this issue is caused by the Android Enterprise DevicePolicyManager.setPasswordExpirationTimeout API behavior with the device management mode.

Resolution

This issue will be resolved on devices running Android 16 OS in a future release fix. To resolve this issue on your corporate-owned device with a work profile, you can disable the password expiration timeout policy from your EMM console or update your device firmware to Android 16.

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