4G and 5G network switching issue on XCover 7
Last updated February 14th, 2025
Categories:
Environment
- Knox Platform for Enterprise
- Samsung Galaxy XCover 7 devices running Android 14 and higher
- Work profile on a company-owned device
Overview
After deploying a work profile on your Samsung Galaxy XCover 7 device, you may notice an issue where the device can switch from a 4G or 5G network to Wi-Fi, but no longer automatically switches from Wi-Fi to a 4G or 5G network.
Cause
Due to feature support misalignment, the MTK chipset in the Samsung Galaxy XCover 7 doesn’t support 5G network slicing. Specifically, the LSI modem doesn’t implement the new IPC introduced in Android 14.
Resolution
To resolve this issue, you can update your device’s firmware version to G556BXXU7BXL2, G556BOXM7BXL2, or later.
If an update is not available, rebooting the device can serve as a workaround to mitigate the issue.
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