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Apps fail to install on device

Last updated October 24th, 2024

Categories:

Environment

  • Devices updating to One UI 6.0 or One UI 6.1

Overview

Following the September 2024 security update for Android 14, device users may encounter an issue where they are unable to install apps on their device.

Cause

The App protection feature on your device and the policy to verify apps on your EMM (in Knox Manage, this is the Verify Apps Using Google Play Protect policy) validates an application before installation. After a device has been turned on if the verification conducted by either App protection or the app verification policy times out or fails, the installation of an app is blocked.

This issue will be addressed in the November update for devices on long term support and the December security maintenance release.

Workaround

Device users may follow the steps below to resolve this issue:

Option 1: Temporarily turn off App Protection

  1. In your work profile, tap Settings > Device Care > App protection.
  2. Tap the menu button (three vertical dots) on the top right corner and turn off App protection.
  3. Wait at least 5 seconds and turn App protection back on.

If the solution above doesn’t resolve the issue, please try Option 2 outlined below:

Option 2: Turn off Auto scan

  1. In your work profile, tap Settings > Device Care > App protection.
  2. Tap the menu button (three vertical dots) on the top right corner and turn off Auto scan when installing apps

If the issue persists following the aforementioned steps, IT admins can turn off the policy to verify apps. Please consult your EMM’s documentation on steps to turn off this policy. If you are using Knox Manage as your EMM, you can follow the steps below:

  1. In the Knox Manage console, click Profile.

  2. Create a new profile or select an existing profile and click Modify Policy.

  3. Under the Android Enterprise policy drawer, click App Restrictions.

  4. Modify the following policies:

    Policy Value
    Verify Apps Using Google Play Protect -
  5. Click Save & Assign > OK to save and push your changes to your device fleet.

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