Unable to install Samsung Calendar app and Samsung Clock app
Last updated February 15th, 2024
Categories:
Environment
- Android Enterprise
- Samsung devices running One UI 5.1.1 and higher
Overview
When enrolling a device, users might encounter an issue where the Samsung Calendar app and Clock app can’t be installed by your EMM. Starting with the following devices, all subsequent devices are affected:
Device | Affected app |
---|---|
Galaxy S23 series | Samsung Clock app |
Galaxy Z Flip5 and Galaxy Z Fold5 | Samsung Calendar app |
Cause
Before One UI 5.1.1, the Samsung Calendar app and Clock app were considered system apps, and could be installed by EMMs with the enableSystemApp() method. For devices that come pre-installed with One UI 5.1.1 or higher, the Samsung Calendar app and Clock app are no longer considered system apps, and are now only available from Google Play.
Resolution
To install the Samsung Calendar app and Clock app on the device by your EMM, the app must be deployed through Managed Google Play. To do so with Knox Manage, see Add apps using Managed Google Play. For other EMMs, consult their documentation.
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