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Error when creating an IBM MaaS360 profile

Last updated July 26th, 2023

Categories:

Environment

  • Knox Mobile Enrollment
  • IBM MaaS360

Overview

When creating an IBM MaaS360 Android Enterprise profile with Knox Mobile Enrollment, the profile creation fails with the error:

Could not create the profile.

Cause

The APK for the IBM MaaS360 agent requires schema V3 signature signing. This feature is not currently supported in Knox Mobile Enrollment.

Resolution

A fix for this issue has been on February 1, 2023. MaaS360 profiles can now be created as outlined in the IBM Knox Mobile Enrollment guide.

Workaround

This workaround is now deprecated, as a fix was released. If this workaround was used, the Knox Mobile Enrollment profile can be edited to use the preset MaaS360 profile, instead of Other. New enrollments will use the updated profile, but prior enrollments aren’t affected unless a factory reset is issued to the device

To create an IBM MaaS360 Android Enterprise profile:

  1. Create a profile in Knox Mobile Enrollment.

  2. Under Pick your MDM, select Other.

  3. For MDM agent APK, enter https://dl.maas360.com/nafo/cdn-content/agents/android/MaaS360Android.apk.

    MDM agent APK field

The Knox Mobile Enrollment team is working on a future software update with V3 signing support for KME. Currently, there is no fixed release timeline.

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