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User access blocked when assigning a profile to devices

Last updated December 12th, 2024

Categories:

Environment

  • Knox Mobile Enrollment

Overview

In Knox Mobile Enrollment, some users are encountering the following error when assigning a profile to a device:

Your access to this service has been blocked.

Cause

The user’s account is missing the necessary permissions in Knox Mobile Enrollment.

Resolution

Only the Super Admin can check or change the permissions assigned to a role unless other admins are also given the permission to view user roles. In Knox Mobile Enrollment, under Administrators and Roles, check that the role that the user is assigned to has the following permissions selected:

Devices and Uploads: Manage devices

  • Assign with profile and manage tags
  • Unassign from profile

Device Users: Manage device users

  • Add, edit, assign and unassign

To add a new admin and manage their roles, see Manage admins and roles.

Additional information

To learn more about how Knox Mobile Enrollment handles admin permissions, see Manage admins and roles.

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