Serious Software Error on Samsung Galaxy company-owned work profile devices in Microsoft Intune
Last updated September 4th, 2025
Categories:
Environment
- Knox Mobile Enrollment
- Microsoft Intune
- Android Enterprise
- Company-owned devices with a work profile
- Samsung Galaxy devices running Android 15 (OneUI 7.0) and higher
Overview
After updating to Android 15 OS (OneUI 7.0) and higher, devices enrolled in Microsoft Intune as company-owned devices with a work profile may encounter a Serious Software Error and a non-functional Phone dialer.
Samsung Galaxy S22 and Galaxy S23 Ultra devices updated to Android 15, and newly purchased Galaxy S25 devices may exhibit this error and are prompted to update. However, this doesn’t resolve the persistent error.
Cause
This issue was caused by a legacy Microsoft Intune policy implemented on Android 11 for company-owned devices with a work profile. The policy was implemented to resolve issues with the work profile Phone dialer and was functional with devices running Android 14 and lower.
The policy has now been removed due to incompatibility with Android 15.
Resolution
To resolve this issue on your devices, you can:
- Ensure the legacy policy that hides the work profile Phone app is removed from enrolled devices.
- If an alternate device management mode suits your needs, re-enroll the affected devices as fully managed devices in Microsoft Intune.
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