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Failed to install internal apps or third-party apps during enrollment

Last updated August 16th, 2024

Categories:

Environment

  • Knox Mobile Enrollment
  • Knox E-FOTA
  • Android zero-touch enrollment
  • Android Enterprise

Overview

If your device fleet is already enrolled in Knox E-FOTA, you might encounter an issue where you’re unable to install third-party apps during the EMM enrollment process. This issue was detected for both Knox Mobile Enrollment or Android zero-touch users.

Cause

This issue is due to the setAllowNonMarketApps() method being set to false. As a result, the device can’t install third-party apps until the enrollment process completes.

Resolution

This issue was resolved in the Knox cloud services 23.12 release. We recommend that you use Knox Mobile Enrollment to enroll your devices into your EMM if you want to install third-party apps during the enrollment process.

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