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Can’t enable NFC through device management software

Last updated April 18th, 2024

Categories:

Environment

  • Knox Mobile Enrollment
  • Knox E-FOTA
  • Fully managed device

Overview

After the Knox cloud services 24.04 release, you might encounter an issue where NFC is unavailable on fully managed devices enrolled through Knox Mobile Enrollment. Any attempt to then change the NFC policy with an EMM fails. Attempting to push the NFC management policy with Knox Service Plugin also fails, producing the following error in the device logs:

Restriction policy block NFC state change

Cause

With the release of Knox cloud services 24.04, a bug was identified where Knox Mobile Enrollment fails to revoke the policy that restricts NFC after enrollment completes. This policy is enforced during enrollment in order to prevent the Android Enterprise NFC enrollment method.

The Knox Mobile Enrollment team is aware of the issue, and is currently working on a fix.

Workaround

NFC can be restored on individual devices through manual re-enrollment. There’s currently no batch solution for this issue.

To allow NFC on a device affected by this issue:

  1. On the device, open a web browser in the primary profile (not the work profile or a Separated Apps folder) and go to https://me.samsungknox.com.
  2. Follow the in-browser instructions to complete re-enrollment.

After re-enrolling the device, NFC functionality is restored.

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