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Incorrect date and time set on devices resulting in a loss in connectivity

Last updated October 17th, 2024

Categories:

Environment

  • Knox Manage
  • Android Enterprise

Overview

You may notice that android devices enrolled in Knox Manage that have an active internet connection regularly lose connectivity with the Knox Manage server.

Cause

This issue occurs when the system clock of the device has the wrong date and time. An incorrect date and time invalidate the certificates that secure communication between the device and the Knox Manage servers, affecting the connectivity between them.

Resolution

To prevent this issue, device users must change the date and time manually to re-establish the connection between the Knox Manage agent and server.

For standard Android devices IT admins can follow these steps:

  1. In the Knox Manage console, click Profile.

  2. Select your desired profile and click Modify Policy.

  3. Under the Android Enterprise policy drawer, select System.

  4. Modify the following polices:

    Policy Value
    Set Date and Time Allow
  5. Click Save & Assign to save and push your changes to the device fleet.

  6. Instruct the device user to adjust the device’s date and time to the current local time. For help with changing the date and time of the device, consult the documentation for the particular device model.

  7. After the device user adjusts the date and time and confirms the error is resolved, you can repeat Steps 1 - 3 and modify the following policy to disallow the device user to set the date and time:

    Policy Value
    Set Date and Time Disallow

For devices configured as kiosks, you can follow these steps to add the Time Zone option in the Kiosk app settings:

  1. In the Knox Manage console, click Kiosk.
  2. Select your kiosk and click Modify.
  3. Expand Advanced Setting, then click Select next to Device Setting.
  4. Select Time Zone and confirm the device settings.
  5. Click Save and update its version.
  6. On the kiosk page, select your kiosk and click Apply.

Additional Reading

For steps on how to set up a profile in Knox Manage, see Create a new profile.

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