Cannot find IMEI on devices enrolled in Knox Manage Legacy
Last updated July 26th, 2023
Categories:
Environment
- Knox Manage (KM) Legacy
- Android 10
Overview
In the KM console, in the Devices menu, the device IMEI is not appearing for Android Q devices enrolled in KM Legacy.
As a result, KM admins are unable to search for any devices for which the IMEI is not displayed.
Cause
By Google’s security design for the Android 10 OS, the Knox SDK API that allows KM to read IMEIs is now deprecated.
Resolution
Due to Android design, this is expected behavior.
Workaround
To ensure that all of your device IMEIs are listed in the KM console, we recommend that you migrate your devices to Android Enterprise.
Additional information
To learn more about Google’s security changes in Android 10, see the Android Developers documentation.
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