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Samsung SDS Cloud Connector (1) Windows background service does not start following a Samsung Cloud Connector installation

Last updated July 26th, 2023

Categories:

Environment

  • Knox Manage (KM)
  • Knox Manage Cloud Connector
  • Windows 2008 R2, 2012, 2016
  • JDK 1.7, 1.8

Overview

Following an installation of Samsung Cloud Connector, the Windows Samsung SDS Cloud Connector background service fails to start. When starting the service, users see the following error message in the Windows event logs:

The description for Event ID 4096 from source ID 4096 from source Samsung SDS Cloud Connector (1) Background Service cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.  If the event originated on another computer, the display information had to be saved with the event.
The following information was included with the event:
LoadLibrary
The specified module could not be found.
The handle is invalid.

Cause

The Java HOME path was not added. The PATH variable should be set to ensure that the Windows Samsung SDS Cloud Connector executable file runs as expected.

Workaround

If the Java HOME path was not added, you must add the full path of the jdk1.8.xxx\bin directory to the PATH variable. The full path typically follows the format of C:\Program Files\Java\jdk1.8.xxx\bin. Follow these steps on Microsoft Windows to set the PATH variable:

  1. Click Start > Control Panel, then System.
  2. Click Advanced, then Environment Variables.
  3. Add the location of the bin folder of the JDK installation for the PATH variable in System Variables. The following is a typical value for the PATH variable: C:\WINDOWS\system32;C:\WINDOWS;C:\Program Files\Java\jdk1.8.xxx\bin

Additional Information

For more information on how to update the PATH Environment Variable, head to Oracle’s Java documentation.

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