VPP apps display ManageButUninstalled status on ADE-enrolled iOS devices

Last updated February 9th, 2026

Categories:

Environment

  • Knox Manage
  • Apple Automated Device Enrollment
  • Public app (Volume Purchase Program and App Store)
  • Device running iOS

Overview

When managing iOS devices enrolled in Knox Manage through Apple’s Automated Device Enrollment (ADE), you may notice an issue where Volume Purchase Program (VPP) apps display the ManageButUninstalled installation status in the Knox Manage console, even when automatic app installation is configured.

Cause

The Knox Manage database tracks apps that are assigned to devices. When it detects an app that is assigned, but isn’t currently installed on a device, the app’s installation status updates to ManageButUninstalled.

The ManageButUninstalled status may occur when:

  • You assign and install a VPP app to a device, but the device user later removes the app from their device.
  • A device user manually installs an assigned VPP app through the App Store or Knox Manage agent, then later uninstalls it.

Resolution

To resolve the VPP app’s ManageButUninstalled status, you can either:

  • Reassign the app: Navigate to the affected device in Knox Manage console, unassign the VPP app, then reassign it to the device with your preferred installation settings.
  • Manually reinstall the app: Instruct the device user to manually reinstall the app through either the App Store or the Knox Manage agent.

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