Enrollment History dashboard displaying incorrect values for day intervals

Last updated December 10th, 2025

Categories:

Environment

  • Knox Manage

Overview

In Knox Manage, you may notice discrepancies on your Enrollment History dashboard between the number of actual device enrollments and the displayed device enrollment count for a given day.

Cause

The device enrollment count discrepancies might be because of a mismatch between your actual time zone and your configured time zone.

The data for the day you log device enrollments is directly queried from your local Knox Manage tenant database. In contrast, the previous day’s data is derived from the aggregated data collected by the internal scheduler.

The schedular begins collecting data from 00:10 of your configured time zone. If your time zone is set to UTC+0 (default setting), it can take an average of two hours to process the previous day’s device enrollments.

This processing gap can result in discrepancies between the real-time device enrollment data from your local Knox Manage tenant database, and the previous day’s aggregated data generated by the scheduler.

Resolution

Configure your time zone setting to your area to avoid fluctuations in your device enrollment count.

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