Can’t use Knox Browser as default browser

Last updated October 24th, 2025

Categories:

Environment

  • Knox Manage

Overview

While using multiple browsers, you might encounter an issue with using Knox Browser as the default browser.

Cause

You might encounter difficulties when accessing certain applications or pages on Knox Browser. For example, when opening a link, the link doesn’t redirect to the appropriate destination on Knox Browser. However, the link does work as intended on another browser. While different browsers can make the applications and pages accessible, they can create vulnerabilities on all devices.

Workaround

To prevent this issue, you can block any other browser you don’t want to be used as the default browser. For example, block Google Chrome or Samsung Internet browser from running. To block a browser:

  1. On the Knox Manage console, go to Profile and select the profile policy you’d like to modify.
  2. On the Set Policy page, go to Android Enterprise > App Restrictions.
  3. Under App Restrictions, set Block Certain Apps from Running to Apply.
  4. On the App List policy field, click Add. The Select Application dialog displays.
  5. Depending on your needs, select the browsers you want to block. If they aren’t present, you can add a new system app:
    1. Click Add System Application.

    2. In the Add System App dialog, set the Platform according to the browser you want to block.

    3. Depending on the browser, enter a Package Name and Application Name. For example:

      Platform Application Name Package Name
      Android Google Chrome com.android.chrome
      Android Samsung Internet Browser com.android.browser.provider
    4. Click Save, then select the browsers.

  6. Click OK to confirm.
  7. Click Save. Alternately, click Save & Assign to push the changes to devices.
  8. In the Save & Assign dialog, click OK to confirm.
  9. If the Profile Version Update dialog displays, click OK to update the profile version.
  10. On the Assign Profile page, select your device(s) and click Assign & Push. The Push Profile dialog displays.
  11. Review the changes and click OK.

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