No notification sounds played on Kiosks
Last updated October 1st, 2025
Environment
- Knox Manage
- Multi-app kiosk
Overview
When using Kiosk mode, you may run into an issue when a new SMS message arrives. The message can be read and is visible in the message count, but no notification sound is played. This issue persists even when the messaging app is added to Multi Apps Mode and Activate Certain Pre-installed System Apps.
Cause
In your Kiosk app settings, your Notification Bar policy is set to Disallow.
Resolution
To enable notification sounds on Kiosks:
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On the Knox Manage console, go to Profile and select the profile policy you’d like to modify.
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On the Set Policy page, go to Android Enterprise > App Restrictions.
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Under App Restrictions, set Activate Certain Pre-installed System Apps to Apply.
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On the App List policy field, click Add. The Select Application dialog displays.
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Depending on your device, select Messages or Google Messages. If neither are present, you can add a new system app:
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Click Add System Application.
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In the Add System App dialog, set Platform to Android.
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Depending on your device, enter a Package Name and Application Name:
Application Name Package Name Messages com.samsung.android.messaging
Google Messages com.google.android.apps.messaging
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Click Save, then select Messages or Google Messages.
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Click OK to confirm.
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In the Android Enterprise policy drawer, click Kiosk.
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Set Utilities Settings to Allow.
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Set Notification Bar to Allow.
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Click Save. Alternately, click Save & Assign to push the changes to devices.
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In the Save & Assign dialog, click OK to confirm.
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If the Profile Version Update dialog displays, click OK to update the profile version.
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On the Assign Profile page, select your device(s) and click Assign & Push. The Push Profile dialog displays.
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Review the changes and click OK.
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