Abnormal Wi-Fi or mobile data traffic
Last updated October 2nd, 2025
Environment
- Knox Manage
- Knox Service Plugin
- Hidden app
Overview
On devices administered through Knox Manage, you may experience abnormal Wi-Fi or mobile data traffic. The huge traffic load occurs when you try to push a profile several times in a scheduled timeframe with an app that has a hidden status on the device.
Cause
Knox Manage doesn’t check if an app is hidden or blocked from running. From the operating system’s perspective, the package is still active and can be updated.
When a hidden app is updated, the APK is downloaded and the installer attempts to install the package. However, the Activity Manager force stops the package installation and PACKAGE_REMOVED
is sent out across the system. As a result, the hidden app is repeatedly downloaded for each profile and consequently managed by the Activity Manager, leading to the abnormal Wi-Fi or mobile data traffic.
Workaround
As a workaround, you can disable a specific package name instead of hiding the app:
-
On the Knox Manage Console, go to Profile and select the profile policy you’d like to modify.
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In the Samsung Knox (Android Enterprise) policy drawer, go to Knox Service Plugin.
-
Set Device-wide polices > Enable device policy controls to True.
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Under Application management policies, apply the following polices:
Policy Value Enable application management controls True Disable Application without user interaction com.example.packagename
, whereexample.packagename
is the name of the hidden package name.For example, to disable Google Chromse Browser, enter
com.android.chrome
. -
Click Save. Alternately, click Save & Assign to push the changes to devices.
-
In the Save & Assign dialog, click OK to confirm.
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If the Profile Version Update dialog displays, click OK to update the profile version.
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On the Assign Profile page, select your device(s) and click Assign & Push. The Push Profile dialog displays.
-
Review the changes and click OK.
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